How can we improve Adobe Dreamweaver?

CPU 100% with node.exe / Evented I/O for V8 JavaScript (32 bit)

There seems to be a correlation between DW 2017 Beta and CPU usage with the "Evented I/O for V8 JavaScript (32 bit)," also showing as "node.exe". The process is often using as much CPU as is available, causing the CPU usage to stay steadily at 100%. When DW 2017 beta closes, that process closes as well, so it certainly appears that they are related. This is happening with DW running, but without any files being open.

2 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    BryceBryce shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Niharika GuptaAdminNiharika Gupta (Sr. Software Engineer, Adobe Dreamweaver) commented  ·   ·  Flag as inappropriate

        Hi,

        Can you please give us more details on the pointers below-

        1. What platform are you using?
        2. Are your sites on network locations? Dropbox?
        3. Are you using CSS Preprocessors/Device Preview?
        4. What is the size of the site, how many files are there in the site?

        We are already investigating a similar issue and your inputs will really be valuable.

        Regards,
        Niharika Gupta
        Adobe Dreamweaver

      • Anonymous commented  ·   ·  Flag as inappropriate

        I am using dreamweaver cc 2017.... the most recent update (which includes the GIT functionality) now causes a node.exe to consume all of my system resources when I launch DW. I have a pretty high-end PC and its frustrating that DW is now unusable.

      • DMeansDMeans commented  ·   ·  Flag as inappropriate

        How come when I start up dreamweaver Node just gets stuck at 100+%
        That's new in this version.

      Feedback and Knowledge Base