Report a bug!

Expand/Collapse -- Unable to Expand Collapsed Section

If find that I will have sections of code that I have collapsed that will no longer expand when clicking on the expand/collapse arrow.

See "Collapsed code block.png" -- This collapsed block of code can't be expanded except by clicking on the gray code snippet that shows what's been collapsed.

Clicking on the gray snippet expands the code but the expand/collapse arrow does not change. See "Expanded via clicking gray snippet.png".

Generally, I've encountered this bug in multiple PHP files that I'm writing. Clicking on the gray box that shows a snippet of the code will expand it, but the arrow remains in the "collapsed" state. Closing and re-opening the file has no effect, nor does closing and re-opening Dreamweaver. I'm guessing this data is stored in a metadata file associated with my site, because I am able to remove and re-add the site and the issue is resolved; albeit with the requirement that I re-add all the site information, servers, etc.

1 vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Michael Kirkpatrick shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • AdminNiharika Gupta (Sr. Software Engineer, Adobe Dreamweaver) commented  ·   ·  Flag as inappropriate

        Hi,

        Thanks for reporting this. Can you please share the following details-

        1. Is it happening consistently?
        2. Can you share the file where it is happening?
        3. Do you have the Code Inspector panel open anytime in the session after launching DW?
        4. What MAC version are you working on, and also the Dw version you are working on?
        5. Can you share a video clip demonstrating the issue happening as it will help us debug and reproduce it at our end as well.

        Regards,
        Niharika Gupta
        Adobe Dreamweaver

      • Bill Dimes commented  ·   ·  Flag as inappropriate

        I'm encountering this same issue and it's very frustrating. Sometimes quitting and restarting DW will fix it, but now it seems stuck and I need to get into that code. I guess I'll try the app pref delete. I hope I don't lose all my site settings.

      • Michael Kirkpatrick commented  ·   ·  Flag as inappropriate

        Final update: I removed all the files/folders in my local ~/Library/Application Support/Adobe/Dreamweaver CC 2017 folder. That resolved my issue, though I had to recreate my app preferences.

      Feedback and Knowledge Base