Report a bug!

Copy/Paste not working

I can't copy or paste on the OSX Dreamweaver CC 2018.
I tried deleting the temp cahce file, restarting DW, and closing the file within DW and opening it again.

The problem is I can't copy FROM DW, and paste into anything else. Pasting within DW works.

24 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    NEED MORE INFO  ·  Adminkragarwa (Admin, Adobe Dreamweaver) responded  · 

    Hi all,

    We are sorry that you are facing issues with DW app.
    We are not able to see this issue at our end.
    For us to better investigate this issue, can you please provide us with answers to the following questions?

    1) What is the document view(full Code view or Live view or split code and live view) that you are copying from and pasting into?
    2) When does the issue start happening? Is it after you switch to another app and come back to DW or you minimise and maximize DW?
    3) Are the pages you are trying to copy from part of Local site root folder or remote site

    Thanks,
    Kratika
    Adobe Dreamweaver Team

    37 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Andre commented  ·   ·  Flag as inappropriate

        I had massive problems before (i posted a solution in this thread before), but since i updated from High Sierra to Mojave the problem didn't occur a single time any more. Hope this info helps the others. Otherwise download the little shell script from my dropbox, it's further down in the comments.

      • Hasmik commented  ·   ·  Flag as inappropriate

        I am experiencing similar issue in documents created with Dreamweaver only when creating and editing in Dreamweaver.

        Copy Paste works as expected in already existing documents created not with Dreamweaver but opened and edited in Dreamweaver.

        Copy does not work in documents created with Dreamweaver. The highlighted snippet shows up underscored and Copy command is disabled in the right click menu. Ctrl + C takes no action either.

        If copied from existing non Dreamweaver created document to Dreamweaver created document then Paste does not work as expected while the document is open. The pasted information becomes visible after saving and restarting that document.

      • Mur commented  ·   ·  Flag as inappropriate

        I have this issue as well didn't realise it was happening (cut and paste all wrong as DW didn't display/update text pasted) so accidentally saved it before quitting and reopened to messed up code. Thank goodness for Time Machine.
        Switching between CODE View: Source Code, Css Code using the mini in doc tabs.
        Open and collapse div code sections within source code.
        Local
        Dreamweaver 19.0
        Mac OS Mojave 10.14.2

      • Ben commented  ·   ·  Flag as inappropriate

        I have been having this ongoing issue for quite some time now. Please Adobe, fix this problem.

      • 匿名 commented  ·   ·  Flag as inappropriate

        There is a clear fact that this issue is bad compatibility between various browsers and DW,
        so it is only a matter of dealing with that issue as soon as possible.

        I can’t understand why Adobe is struggling so hard...

      • Tony Sanfilippo commented  ·   ·  Flag as inappropriate

        I'm also having this issue.

        Doesn't work with both DW17, Build 9315 or DW18, Build 10136. Very problematic.

      • Anonymous commented  ·   ·  Flag as inappropriate

        It may be a Chrome issue, not an Adobe issue. I was able to bypass this with using Safari while working with WordPress.

        Worked like a charm.

      • Anonymous commented  ·   ·  Flag as inappropriate

        This is reported all over the Adobe forum, for a long time now, with people feeding the info you are requesting all a long.

        1. code view
        2. at some point switching between apps
        3. pages are local

      • andrebalestrini commented  ·   ·  Flag as inappropriate

        I have resolved the problem with the app "Copy em'paste" in apple store.
        On "preference > configure Copy & Paste for special app" and select Dreamweaver...
        Best regards, andre

      • 匿名 commented  ·   ·  Flag as inappropriate

        This issue still remains in CC2019!!!!!!!!!!!!!!!!
        I'm soooooooooooooooooooooooo furious!!!!!!!!!!!!!!!!

      • DA commented  ·   ·  Flag as inappropriate

        Same issue, been having it for months.

        1. Code or split view
        2. Issue occurs when copying code into Chrome. Minimize/maximize doesn't change anything.
        3. Occasionally local site; frequently generating new code and copying from DW to Chrome.

      • Anonymous commented  ·   ·  Flag as inappropriate

        1) What is the document view(full Code view or Live view or split code and live view) that you are copying from and pasting into? IN SPLIT or CODE VIEW -- DESIGN VIEW

        2) When does the issue start happening? Is it after you switch to another app and come back to DW or you minimise and maximize DW? STARTS ABOUT 30 MINUTES AFTER USING, I AM BOUNCING BACK AND FORTH BETWEEN MULTIPLE APPS, MOSTLY JUST EMAIL AND BROWSERS (SAFARI, CHROME AND FIREFOX)

        3) Are the pages you are trying to copy from part of Local site root folder or remote site. FROM A SMALL SHORT PAGE, COPYING CODE AND PASTING IT INTO A BROWSER. USING AS A TEXT EDITOR

      • Anonymous commented  ·   ·  Flag as inappropriate

        has this been fix yet? - It's really affecting my workflow and deadlines. - C'MON ADOBE!

      • Alex commented  ·   ·  Flag as inappropriate

        Every time I use DreamWeaver copy/paste stops working between applications, it works within the same application but if I want to copy between the browser and Dreamweaver for example, it won't work. I have to constantly quit the "pboard" process to clear the clipping board. Then it works once and I have to quit the pboard again. This is extremely frustrating as we are dealing with code and copy/paste is used all the time!

        Please Fix this issue ASAP!

        I'm using Adobe CC 2818
        Dreamweaver v18.2 - Build 10165
        MacOS High Sierra 10.13.6 (17G65)

      ← Previous 1

      Feedback and Knowledge Base